aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-06-22 22:39:39 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-06-22 22:39:39 +0200
commit68bc2978099ba0e17045f943081f88fd84eddf92 (patch)
tree9eb77cfa09a64f2f5f913679dc8d3503276f048d /CMakeLists.txt
parent933760c2a26732634e86f6695549fb7834b3bb49 (diff)
downloadxK-68bc2978099ba0e17045f943081f88fd84eddf92.tar.gz
xK-68bc2978099ba0e17045f943081f88fd84eddf92.tar.xz
xK-68bc2978099ba0e17045f943081f88fd84eddf92.zip
Bump liberty
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fef2385..87db34a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,8 +8,8 @@ option (WANT_LIBEDIT "Use BSD libedit for the UI" OFF)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# -Wunused-function is pretty annoying here, as everything is static
- set (CMAKE_C_FLAGS
- "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra -Wno-unused-function")
+ set (wdisabled "-Wno-unused-function -Wno-implicit-fallthrough")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra ${wdisabled}")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# Version