aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2016-03-10 20:26:35 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2016-03-10 20:26:35 +0100
commit5a197162bfa3cb9709ffc401eb001e94bc4c5296 (patch)
treecfc4321e7a68cafa5a94e5ca8ae5f6f88f023ba5 /CMakeLists.txt
parentd70f156a201249053b19b339a95c4c5b55387ad2 (diff)
downloadxK-5a197162bfa3cb9709ffc401eb001e94bc4c5296.tar.gz
xK-5a197162bfa3cb9709ffc401eb001e94bc4c5296.tar.xz
xK-5a197162bfa3cb9709ffc401eb001e94bc4c5296.zip
Fix manpage generation
The manpages could end up in a wrong directory.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad131bf..32aba0c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -202,7 +202,7 @@ endforeach (page)
add_custom_target (docs ALL DEPENDS ${project_MAN_PAGES})
foreach (page ${project_MAN_PAGES})
- string (REGEX MATCH "\\.([0-9])" manpage_suffix "${page}")
+ string (REGEX MATCH "\\.([0-9])$" manpage_suffix "${page}")
install (FILES "${page}"
DESTINATION "${CMAKE_INSTALL_MANDIR}/man${CMAKE_MATCH_1}")
endforeach (page)