aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2016-03-06 17:59:45 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2016-03-06 18:12:12 +0100
commit584d2f0295df01cff4ac24c336af40f4c2a762e2 (patch)
tree41b59d84fb0c82bfa119c02f78bbc845c9d1c776 /CMakeLists.txt
parent3304b718aac98103b5fb3c2855bb661887c62aa1 (diff)
downloadxK-584d2f0295df01cff4ac24c336af40f4c2a762e2.tar.gz
xK-584d2f0295df01cff4ac24c336af40f4c2a762e2.tar.xz
xK-584d2f0295df01cff4ac24c336af40f4c2a762e2.zip
degesch: use libffi to unify input callbacks
And fuck you both, Readline and Editline.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1213ab6..ad131bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,7 +39,7 @@ include (AddThreads)
find_package (Curses)
find_package (PkgConfig REQUIRED)
-pkg_check_modules (libssl REQUIRED libssl libcrypto)
+pkg_check_modules (dependencies REQUIRED libssl libcrypto libffi)
pkg_check_modules (ncursesw ncursesw)
if ("${CMAKE_SYSTEM_NAME}" MATCHES "BSD")
@@ -50,9 +50,9 @@ if ("${CMAKE_SYSTEM_NAME}" MATCHES "BSD")
add_definitions (-D__BSD_VISIBLE=1 -D_BSD_SOURCE=1)
endif ("${CMAKE_SYSTEM_NAME}" MATCHES "BSD")
-list (APPEND project_libraries ${libssl_LIBRARIES})
-include_directories (${libssl_INCLUDE_DIRS})
-link_directories (${libssl_LIBRARY_DIRS})
+list (APPEND project_libraries ${dependencies_LIBRARIES})
+include_directories (${dependencies_INCLUDE_DIRS})
+link_directories (${dependencies_LIBRARY_DIRS})
# FIXME: other Lua versions may be acceptable, don't know yet
pkg_search_module (lua lua53 lua5.3 lua-5.3 lua>=5.3)