aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-08-06 16:12:15 +0200
committerPřemysl Eric Janouch <p@janouch.name>2021-08-06 16:43:59 +0200
commit50057d5149dda340b3b47aca4096f4a6ec66b9ee (patch)
tree79323d20b17c2c8e32942a1ac9b84d9da3041c6d /CMakeLists.txt
parent1f64710e795b0c5434d15813d4f1f568467ca087 (diff)
downloadxK-50057d5149dda340b3b47aca4096f4a6ec66b9ee.tar.gz
xK-50057d5149dda340b3b47aca4096f4a6ec66b9ee.tar.xz
xK-50057d5149dda340b3b47aca4096f4a6ec66b9ee.zip
Come up with sillier names for the binaries
I'm not entirely sure, but it looks like some people might not like jokes about the Holocaust. On a more serious note, the project has become more serious over the 7 or so years of its existence.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt60
1 files changed, 30 insertions, 30 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a18ebca..9c1d39b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -77,9 +77,9 @@ CHECK_C_SOURCE_RUNS ("#include <iconv.h>
int main () { return iconv_open (\"UTF-8//TRANSLIT\", \"ISO-8859-1\")
== (iconv_t) -1; }" ICONV_ACCEPTS_TRANSLIT)
-# Dependencies for degesch
+# Dependencies for xC
pkg_check_modules (libffi REQUIRED libffi)
-list (APPEND degesch_libraries ${libffi_LIBRARIES})
+list (APPEND xC_libraries ${libffi_LIBRARIES})
include_directories (${libffi_INCLUDE_DIRS})
link_directories (${libffi_LIBRARY_DIRS})
@@ -92,7 +92,7 @@ if (WITH_LUA)
message (FATAL_ERROR "Lua library not found")
endif ()
- list (APPEND degesch_libraries ${lua_LIBRARIES})
+ list (APPEND xC_libraries ${lua_LIBRARIES})
include_directories (${lua_INCLUDE_DIRS})
link_directories (${lua_LIBRARY_DIRS})
endif ()
@@ -100,10 +100,10 @@ endif ()
find_package (Curses)
pkg_check_modules (ncursesw ncursesw)
if (ncursesw_FOUND)
- list (APPEND degesch_libraries ${ncursesw_LIBRARIES})
+ list (APPEND xC_libraries ${ncursesw_LIBRARIES})
include_directories (${ncursesw_INCLUDE_DIRS})
elseif (CURSES_FOUND)
- list (APPEND degesch_libraries ${CURSES_LIBRARY})
+ list (APPEND xC_libraries ${CURSES_LIBRARY})
include_directories (${CURSES_INCLUDE_DIR})
else ()
message (SEND_ERROR "Curses not found")
@@ -115,13 +115,13 @@ elseif (WANT_READLINE)
# OpenBSD's default readline is too old
if ("${CMAKE_SYSTEM_NAME}" MATCHES "OpenBSD")
include_directories (${OPENBSD_LOCALBASE}/include/ereadline)
- list (APPEND degesch_libraries ereadline)
+ list (APPEND xC_libraries ereadline)
else ()
- list (APPEND degesch_libraries readline)
+ list (APPEND xC_libraries readline)
endif ()
elseif (WANT_LIBEDIT)
pkg_check_modules (libedit REQUIRED libedit)
- list (APPEND degesch_libraries ${libedit_LIBRARIES})
+ list (APPEND xC_libraries ${libedit_LIBRARIES})
include_directories (${libedit_INCLUDE_DIRS})
endif ()
@@ -135,34 +135,34 @@ configure_file (${PROJECT_SOURCE_DIR}/config.h.in ${PROJECT_BINARY_DIR}/config.h
include_directories (${PROJECT_SOURCE_DIR} ${PROJECT_BINARY_DIR})
# Generate IRC replies--we need a custom target because of the multiple outputs
-add_custom_command (OUTPUT kike-replies.c kike.msg
- COMMAND ${PROJECT_SOURCE_DIR}/kike-gen-replies.sh
- > kike-replies.c < ${PROJECT_SOURCE_DIR}/kike-replies
- DEPENDS ${PROJECT_SOURCE_DIR}/kike-replies
+add_custom_command (OUTPUT xD-replies.c xD.msg
+ COMMAND ${PROJECT_SOURCE_DIR}/xD-gen-replies.sh
+ > xD-replies.c < ${PROJECT_SOURCE_DIR}/xD-replies
+ DEPENDS ${PROJECT_SOURCE_DIR}/xD-replies
COMMENT "Generating files from the list of server numerics")
-add_custom_target (replies DEPENDS ${PROJECT_BINARY_DIR}/kike-replies.c)
+add_custom_target (replies DEPENDS ${PROJECT_BINARY_DIR}/xD-replies.c)
# Build
-foreach (name zyklonb degesch kike)
+foreach (name xB xC xD)
add_executable (${name} ${name}.c ${PROJECT_BINARY_DIR}/config.h)
target_link_libraries (${name} ${project_libraries})
add_threads (${name})
endforeach ()
-add_dependencies (kike replies)
-add_dependencies (degesch replies)
-target_link_libraries (degesch ${degesch_libraries})
+add_dependencies (xD replies)
+add_dependencies (xC replies)
+target_link_libraries (xC ${xC_libraries})
# Tests
include (CTest)
if (BUILD_TESTING)
- add_executable (test-degesch $<TARGET_PROPERTY:degesch,SOURCES>)
- set_target_properties (test-degesch PROPERTIES COMPILE_DEFINITIONS TESTING)
- target_link_libraries (test-degesch $<TARGET_PROPERTY:degesch,LINK_LIBRARIES>)
- add_threads (test-degesch)
- add_dependencies (test-degesch replies)
+ add_executable (test-xC $<TARGET_PROPERTY:xC,SOURCES>)
+ set_target_properties (test-xC PROPERTIES COMPILE_DEFINITIONS TESTING)
+ target_link_libraries (test-xC $<TARGET_PROPERTY:xC,LINK_LIBRARIES>)
+ add_threads (test-xC)
+ add_dependencies (test-xC replies)
- add_test (NAME test-degesch COMMAND test-degesch)
+ add_test (NAME test-xC COMMAND test-xC)
add_test (NAME custom-static-analysis
COMMAND ${PROJECT_SOURCE_DIR}/test-static)
endif ()
@@ -182,13 +182,13 @@ add_custom_target (clang-tidy
WORKING_DIRECTORY ${PROJECT_SOURCE_DIR})
# Installation
-install (TARGETS zyklonb degesch kike DESTINATION ${CMAKE_INSTALL_BINDIR})
+install (TARGETS xB xC xD DESTINATION ${CMAKE_INSTALL_BINDIR})
install (FILES LICENSE DESTINATION ${CMAKE_INSTALL_DOCDIR})
# XXX: our defaults for XDG_DATA_DIRS expect /usr/local/shore or /usr/share
-install (DIRECTORY plugins/zyklonb/
- DESTINATION ${CMAKE_INSTALL_DATADIR}/zyklonb/plugins USE_SOURCE_PERMISSIONS)
-install (DIRECTORY plugins/degesch/
- DESTINATION ${CMAKE_INSTALL_DATADIR}/degesch/plugins)
+install (DIRECTORY plugins/xB/
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/xB/plugins USE_SOURCE_PERMISSIONS)
+install (DIRECTORY plugins/xC/
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/xC/plugins)
# Generate documentation from text markup
find_program (ASCIIDOCTOR_EXECUTABLE asciidoctor)
@@ -196,7 +196,7 @@ if (NOT ASCIIDOCTOR_EXECUTABLE)
message (FATAL_ERROR "asciidoctor not found")
endif ()
-foreach (page zyklonb degesch kike)
+foreach (page xB xC xD)
set (page_output "${PROJECT_BINARY_DIR}/${page}.1")
list (APPEND project_MAN_PAGES "${page_output}")
add_custom_command (OUTPUT ${page_output}
@@ -217,7 +217,7 @@ foreach (page ${project_MAN_PAGES})
endforeach ()
# CPack
-set (CPACK_PACKAGE_DESCRIPTION_SUMMARY "Unethical IRC client, daemon and bot")
+set (CPACK_PACKAGE_DESCRIPTION_SUMMARY "Unreasonable IRC client, daemon and bot")
set (CPACK_PACKAGE_VERSION "${project_version_safe}")
set (CPACK_PACKAGE_VENDOR "Premysl Eric Janouch")
set (CPACK_PACKAGE_CONTACT "Přemysl Eric Janouch <p@janouch.name>")