aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2025-01-06 17:13:30 +0100
committerPřemysl Eric Janouch <p@janouch.name>2025-01-08 06:40:52 +0100
commit278a7f95a9f50489f371b7137eff8a342b494fdf (patch)
treef23a43d502e4b7575801bdf4963e153419a2b0af /CMakeLists.txt
parenta8575ab8757c3c22c534bcebd2558c712bc6df90 (diff)
downloadxK-278a7f95a9f50489f371b7137eff8a342b494fdf.tar.gz
xK-278a7f95a9f50489f371b7137eff8a342b494fdf.tar.xz
xK-278a7f95a9f50489f371b7137eff8a342b494fdf.zip
Port the integration test from expect to wdye
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2263af0..e49d6a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -210,6 +210,11 @@ if (BUILD_TESTING)
add_test (NAME custom-static-analysis
COMMAND ${PROJECT_SOURCE_DIR}/test-static)
endif ()
+option (BUILD_TESTING_WDYE "..." OFF)
+if (BUILD_TESTING_WDYE)
+ add_subdirectory (liberty/tools/wdye)
+ add_test (NAME integration COMMAND wdye "${PROJECT_SOURCE_DIR}/test.lua")
+endif ()
# Various clang-based diagnostics, loads of fake positives and spam
file (GLOB clang_tidy_sources *.c)