aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-05-05 08:58:44 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2015-05-05 08:58:44 +0200
commit1acd41eafe82a432fa98b6df280f6128b31b005e (patch)
tree0b5c17240c75485fa93fb4a9584a6777d03ad7ff /CMakeLists.txt
parenta5a1079a9c0c96242db9d0b894bf92fbb4fbbf55 (diff)
downloadxK-1acd41eafe82a432fa98b6df280f6128b31b005e.tar.gz
xK-1acd41eafe82a432fa98b6df280f6128b31b005e.tar.xz
xK-1acd41eafe82a432fa98b6df280f6128b31b005e.zip
degesch: fix README by fixing CMakeLists.txt
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0840b00..bcb84ec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,7 @@ cmake_minimum_required (VERSION 2.8.5)
# Options
option (WANT_READLINE "Use GNU Readline for the UI (better)" ON)
-option (WANT_EDITLINE "Use BSD libedit for the UI" OFF)
+option (WANT_LIBEDIT "Use BSD libedit for the UI" OFF)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
@@ -42,24 +42,24 @@ else (CURSES_FOUND)
message (SEND_ERROR "Curses not found")
endif (ncursesw_FOUND)
-if ((WANT_READLINE AND WANT_EDITLINE) OR (NOT WANT_READLINE AND NOT WANT_EDITLINE))
+if ((WANT_READLINE AND WANT_LIBEDIT) OR (NOT WANT_READLINE AND NOT WANT_LIBEDIT))
message (SEND_ERROR "You have to choose either GNU Readline or libedit")
elseif (WANT_READLINE)
list (APPEND project_libraries readline)
-elseif (WANT_EDITLINE)
+elseif (WANT_LIBEDIT)
pkg_check_modules (libedit REQUIRED libedit)
list (APPEND project_libraries ${libedit_LIBRARIES})
include_directories (${libedit_INCLUDE_DIRS})
-endif ((WANT_READLINE AND WANT_EDITLINE) OR (NOT WANT_READLINE AND NOT WANT_EDITLINE))
+endif ((WANT_READLINE AND WANT_LIBEDIT) OR (NOT WANT_READLINE AND NOT WANT_LIBEDIT))
# Generate a configuration file
if (WANT_READLINE)
set (HAVE_READLINE 1)
endif (WANT_READLINE)
-if (WANT_EDITLINE)
+if (WANT_LIBEDIT)
set (HAVE_EDITLINE 1)
-endif (WANT_EDITLINE)
+endif (WANT_LIBEDIT)
include (GNUInstallDirs)
set (plugin_dir ${CMAKE_INSTALL_LIBDIR}/${PROJECT_NAME})