aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2016-03-06 03:50:35 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2016-03-06 03:50:35 +0100
commit10bdf90fe25933148df7e5962d3e56a902a3185c (patch)
tree41a151aeb79bb4478477e09cb5a3df53712d5681 /CMakeLists.txt
parent17804fa49b1f7b56ea05567202e708332f8da70c (diff)
downloadxK-10bdf90fe25933148df7e5962d3e56a902a3185c.tar.gz
xK-10bdf90fe25933148df7e5962d3e56a902a3185c.tar.xz
xK-10bdf90fe25933148df7e5962d3e56a902a3185c.zip
Don't force override compile flags
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ffe3f6..b6a82ad 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,7 +8,8 @@ option (WANT_LIBEDIT "Use BSD libedit for the UI" OFF)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# -Wunused-function is pretty annoying here, as everything is static
- set (CMAKE_C_FLAGS "-std=c99 -Wall -Wextra -Wno-unused-function")
+ set (CMAKE_C_FLAGS
+ "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra -Wno-unused-function")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# Version