aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2014-10-18 20:34:53 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2014-10-22 22:22:26 +0200
commit70bcfde0212b4009467f8551c197743b70355b99 (patch)
tree7fae97c86695ab8ad13cd818f09c57bc67b9b5f8 /CMakeLists.txt
parent86025fcf6fd8b58de0dee23c4fd2c33daad38e17 (diff)
downloadtermo-70bcfde0212b4009467f8551c197743b70355b99.tar.gz
termo-70bcfde0212b4009467f8551c197743b70355b99.tar.xz
termo-70bcfde0212b4009467f8551c197743b70355b99.zip
Add a demo for drawing in curses
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29c81e1..c68e5b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,10 +74,13 @@ set_target_properties (termo-static PROPERTIES
add_executable (demo-async EXCLUDE_FROM_ALL demo-async.c)
target_link_libraries (demo-async termo-static ${lib_libraries})
+add_executable (demo-draw EXCLUDE_FROM_ALL demo-draw.c)
+target_link_libraries (demo-draw termo-static ${lib_libraries})
+
add_executable (demo EXCLUDE_FROM_ALL demo.c)
target_link_libraries (demo termo-static ${lib_libraries})
-set (demos demo demo-async)
+set (demos demo demo-async demo-draw)
if (glib_FOUND)
include_directories (${glib_INCLUDE_DIRS})
add_executable (demo-glib EXCLUDE_FROM_ALL demo-glib.c)