aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 46c2cbc..b76df12 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,9 +72,11 @@ if (USE_SYSTEM_TERMO)
message (FATAL_ERROR "System termo library not found")
endif ()
else ()
- # We don't want the library to install, even though EXCLUDE_FROM_ALL
- # sabotages CTest -- those unbuilt tests need to be excluded in CTest runs
+ # We don't want the library to install, but EXCLUDE_FROM_ALL ignores tests
add_subdirectory (termo EXCLUDE_FROM_ALL)
+ file (WRITE ${PROJECT_BINARY_DIR}/CTestCustom.cmake
+ "execute_process (COMMAND ${CMAKE_COMMAND} --build termo)")
+
# We don't have many good choices; this is a relatively clean approach
# (other possibilities: setting a variable in the parent scope, using
# a cache variable, writing a special config file with build paths in it