aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2020-09-03 23:17:17 +0200
committerPřemysl Eric Janouch <p@janouch.name>2020-09-04 00:13:34 +0200
commit8d19acd91af9592d862ef2a7aa8e95eea4160152 (patch)
treefb2a422cf9446829c41e152415f128b47babe938 /CMakeLists.txt
parentdd2bd04a07030f15e6eb6875041f95c74023dd35 (diff)
downloadtdv-8d19acd91af9592d862ef2a7aa8e95eea4160152.tar.gz
tdv-8d19acd91af9592d862ef2a7aa8e95eea4160152.tar.xz
tdv-8d19acd91af9592d862ef2a7aa8e95eea4160152.zip
Add a tool to transform dictionaries
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 8 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6edd410..3bb97aa 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -180,15 +180,14 @@ add_executable (${PROJECT_NAME}
target_link_libraries (${PROJECT_NAME} ${project_common_libraries})
# Tools
-add_executable (query-tool EXCLUDE_FROM_ALL
- src/query-tool.c ${project_common_sources})
-target_link_libraries (query-tool ${project_common_libraries})
-
-add_executable (add-pronunciation EXCLUDE_FROM_ALL
- src/add-pronunciation.c ${project_common_sources})
-target_link_libraries (add-pronunciation ${project_common_libraries})
-
-add_custom_target (tools DEPENDS add-pronunciation query-tool)
+set (tools add-pronunciation query-tool transform)
+foreach (tool ${tools})
+ add_executable (${tool} EXCLUDE_FROM_ALL
+ src/${tool}.c ${project_common_sources})
+ target_link_libraries (${tool} ${project_common_libraries})
+endforeach (tool)
+
+add_custom_target (tools DEPENDS ${tools})
# The files to be installed
include (GNUInstallDirs)