aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2013-05-19 02:46:05 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2013-05-19 05:04:37 +0200
commit46083b1e7deaf5a323a86f94bf64924f63b59d9b (patch)
tree049184049e4a9e7ce6b71f1169eef35fca74b591 /CMakeLists.txt
parentc430b6d7f89deaee45eaee350ef88a440b34cb29 (diff)
downloadtdv-46083b1e7deaf5a323a86f94bf64924f63b59d9b.tar.gz
tdv-46083b1e7deaf5a323a86f94bf64924f63b59d9b.tar.xz
tdv-46083b1e7deaf5a323a86f94bf64924f63b59d9b.zip
Internationalisation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fe93d77..e83ddc1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,13 @@ pkg_check_modules (dependencies REQUIRED ncursesw glib-2.0 gio-2.0 pango)
include_directories (${dependencies_INCLUDE_DIRS})
+# Localization
+find_package (Gettext REQUIRED)
+file (GLOB project_PO_FILES ${CMAKE_CURRENT_SOURCE_DIR}/po/*.po)
+GETTEXT_CREATE_TRANSLATIONS (
+ ${CMAKE_CURRENT_SOURCE_DIR}/po/${CMAKE_PROJECT_NAME}.pot
+ ALL ${project_PO_FILES})
+
# Project source files
set (project_common_sources
src/generator.c