summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2013-06-02 00:01:23 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2013-06-02 00:04:43 +0200
commit1cc91a4b179b13c19d3318e64896088fefde6c3c (patch)
tree21dbf2d46a4a1e62df8b472773fdd2141f4d0553 /CMakeLists.txt
parentd3b966a93f176ce669f228b0d0dad0b9682c3e11 (diff)
downloadtdv-1cc91a4b179b13c19d3318e64896088fefde6c3c.tar.gz
tdv-1cc91a4b179b13c19d3318e64896088fefde6c3c.tar.xz
tdv-1cc91a4b179b13c19d3318e64896088fefde6c3c.zip
Fix double- and zero-wide characters
It's not perfect but seems to work well enough.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb40db7..ad2f2df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,10 @@ set (project_VERSION "${project_VERSION_MAJOR}")
set (project_VERSION "${project_VERSION}.${project_VERSION_MINOR}")
set (project_VERSION "${project_VERSION}.${project_VERSION_PATCH}")
+# Configuration
+include (CheckFunctionExists)
+CHECK_FUNCTION_EXISTS ("wcwidth" HAVE_WCWIDTH)
+
# Dependecies
find_package (PkgConfig REQUIRED)
pkg_check_modules (dependencies REQUIRED ncursesw glib-2.0 gio-2.0 pango)