From 1cc91a4b179b13c19d3318e64896088fefde6c3c Mon Sep 17 00:00:00 2001
From: Přemysl Janouch
Date: Sun, 2 Jun 2013 00:01:23 +0200
Subject: Fix double- and zero-wide characters
It's not perfect but seems to work well enough.
---
CMakeLists.txt | 4 ++++
1 file changed, 4 insertions(+)
(limited to 'CMakeLists.txt')
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eb40db7..ad2f2df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,10 @@ set (project_VERSION "${project_VERSION_MAJOR}")
set (project_VERSION "${project_VERSION}.${project_VERSION_MINOR}")
set (project_VERSION "${project_VERSION}.${project_VERSION_PATCH}")
+# Configuration
+include (CheckFunctionExists)
+CHECK_FUNCTION_EXISTS ("wcwidth" HAVE_WCWIDTH)
+
# Dependecies
find_package (PkgConfig REQUIRED)
pkg_check_modules (dependencies REQUIRED ncursesw glib-2.0 gio-2.0 pango)
--
cgit v1.2.3-70-g09d2