aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2024-12-28 18:59:45 +0100
committerPřemysl Eric Janouch <p@janouch.name>2024-12-29 02:58:35 +0100
commitb070df60106e1f2890119c17b12c9f53c932b587 (patch)
treeda510bc479af728036b3efdad3ff4e120d90d5e3 /CMakeLists.txt
parent3075d47aeb52f6549e957023d353d4c5cb857e54 (diff)
downloadsdn-b070df60106e1f2890119c17b12c9f53c932b587.tar.gz
sdn-b070df60106e1f2890119c17b12c9f53c932b587.tar.xz
sdn-b070df60106e1f2890119c17b12c9f53c932b587.zip
Rewrite sdn-view AWK core in C++
sdn-view is still slower than I'd like it to be, just no longer ridiculously so.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 87a2c7e..d0a6042 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,9 +26,14 @@ target_compile_features (${PROJECT_NAME} PUBLIC cxx_std_14)
target_compile_definitions (${PROJECT_NAME} PUBLIC
-DPROJECT_NAME=\"${PROJECT_NAME}\" -DPROJECT_VERSION=\"${PROJECT_VERSION}\")
+add_executable (${PROJECT_NAME}-mc-ext ${PROJECT_NAME}-mc-ext.cpp)
+target_compile_features (${PROJECT_NAME}-mc-ext PUBLIC cxx_std_17)
+
include (GNUInstallDirs)
-install (TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
-install (PROGRAMS ${PROJECT_NAME}-install ${PROJECT_NAME}-view
+# sdn-mc-ext should be in libexec, but we prefer it in PATH.
+install (TARGETS sdn sdn-mc-ext
+ DESTINATION ${CMAKE_INSTALL_BINDIR})
+install (PROGRAMS sdn-install sdn-view
DESTINATION ${CMAKE_INSTALL_BINDIR})
install (FILES sdn.1 sdn-install.1 sdn-view.1
DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)