aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2020-10-21 08:18:39 +0200
committerPřemysl Eric Janouch <p@janouch.name>2020-10-21 08:26:42 +0200
commita0eacf4607f0262f6c3bb6ddf84113253b76d477 (patch)
treeb0876042de898b9667b7d4e4fc267b3722e83c97 /CMakeLists.txt
parent37ad5f43df0d83301447c659340570d8d2637912 (diff)
downloadsdn-a0eacf4607f0262f6c3bb6ddf84113253b76d477.tar.gz
sdn-a0eacf4607f0262f6c3bb6ddf84113253b76d477.tar.xz
sdn-a0eacf4607f0262f6c3bb6ddf84113253b76d477.zip
Add an installation script
Copying snippets from the README was uncomfortable and laborious, and wasted a lot of space in the document, especially after the recent additions. Closes #3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9c6d06b..e6cba04 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,6 +27,7 @@ target_compile_definitions (${PROJECT_NAME} PUBLIC
include (GNUInstallDirs)
install (TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
+install (PROGRAMS ${PROJECT_NAME}-install DESTINATION ${CMAKE_INSTALL_BINDIR})
install (FILES LICENSE DESTINATION ${CMAKE_INSTALL_DOCDIR})
set (CPACK_PACKAGE_DESCRIPTION_SUMMARY "Directory navigator")