aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2023-08-01 03:11:11 +0200
committerPřemysl Eric Janouch <p@janouch.name>2023-08-01 03:11:11 +0200
commit9ddeb036526a2b2ae7cb0144d239b40b88517914 (patch)
treeec03db63824f67426f309a68430a228f1ee25f19 /CMakeLists.txt
parentacb187c6b17429dfaddbb05d88cffc3b629dc1a2 (diff)
downloadsdn-9ddeb036526a2b2ae7cb0144d239b40b88517914.tar.gz
sdn-9ddeb036526a2b2ae7cb0144d239b40b88517914.tar.xz
sdn-9ddeb036526a2b2ae7cb0144d239b40b88517914.zip
CMakeLists.txt: declare compatibility with 3.27
Sadly, the 3.5 deprecation warning doesn't go away after this.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0bef602..175139a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
# target_compile_features has been introduced in that version
-cmake_minimum_required (VERSION 3.1)
+cmake_minimum_required (VERSION 3.1...3.27)
project (sdn VERSION 0.1 LANGUAGES CXX)
if ("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU")