aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-07-19 09:12:36 +0200
committerPřemysl Eric Janouch <p@janouch.name>2021-07-19 09:23:28 +0200
commit3eea106c3c856b1f75823df4b51e3fb152014086 (patch)
tree986340f4ed071ab5569a3f817c035bc994cc7f95 /CMakeLists.txt
parent7de8c84e8f996ece9b5af00ffbca9de9effcb472 (diff)
downloadsdn-3eea106c3c856b1f75823df4b51e3fb152014086.tar.gz
sdn-3eea106c3c856b1f75823df4b51e3fb152014086.tar.xz
sdn-3eea106c3c856b1f75823df4b51e3fb152014086.zip
Explicitly disable GCC's -Wmisleading-indentation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7518f4f..0bef602 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,7 +3,8 @@ cmake_minimum_required (VERSION 3.1)
project (sdn VERSION 0.1 LANGUAGES CXX)
if ("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU")
- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -pedantic")
+ set (CMAKE_CXX_FLAGS
+ "${CMAKE_CXX_FLAGS} -Wall -Wextra -Wno-misleading-indentation -pedantic")
endif ()
# Since we use a language with slow compilers, let's at least use a fast linker