aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2016-03-11 20:34:38 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2016-03-11 20:34:38 +0100
commitd3d709e994061108d594361607c92d65455ac2ba (patch)
treebd13a707dae75c6d0f2be8bc4eb739b0b22d5d0b /CMakeLists.txt
parent9c16e197865a7e2effe7902f4c4a16857b7fa878 (diff)
downloadponymap-d3d709e994061108d594361607c92d65455ac2ba.tar.gz
ponymap-d3d709e994061108d594361607c92d65455ac2ba.tar.xz
ponymap-d3d709e994061108d594361607c92d65455ac2ba.zip
Fix packaging, update README
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b128e9c..87c81d4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,8 @@ cmake_minimum_required (VERSION 2.8.5)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# -Wunused-function is pretty annoying here, as everything is static
- set (CMAKE_C_FLAGS "-std=c99 -Wall -Wextra -Wno-unused-function")
+ set (CMAKE_C_FLAGS
+ "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra -Wno-unused-function")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# Version
@@ -130,7 +131,7 @@ endforeach (page)
add_custom_target (docs ALL DEPENDS ${project_MAN_PAGES})
foreach (page ${project_MAN_PAGES})
- string (REGEX MATCH "\\.([0-9])" manpage_suffix "${page}")
+ string (REGEX MATCH "\\.([0-9])$" manpage_suffix "${page}")
install (FILES "${page}"
DESTINATION "${CMAKE_INSTALL_MANDIR}/man${CMAKE_MATCH_1}")
endforeach (page)