aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2023-06-29 02:24:59 +0200
committerPřemysl Eric Janouch <p@janouch.name>2023-06-29 02:25:23 +0200
commitc420e3ce861bff2433c7f3e6da3bb9df18c8e095 (patch)
treed76b4be3db76f7305080ffa0b9ba82c9020dff7b /CMakeLists.txt
parent11567dc05cba0c8c5cd36523063066666a212caf (diff)
downloadponymap-c420e3ce861bff2433c7f3e6da3bb9df18c8e095.tar.gz
ponymap-c420e3ce861bff2433c7f3e6da3bb9df18c8e095.tar.xz
ponymap-c420e3ce861bff2433c7f3e6da3bb9df18c8e095.zip
Fix plugin search path on Nix
Even its non-full GNUInstallDirs paths are absolute, which is apparently allowed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6750eb9..fb004be 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,6 +70,7 @@ set (project_headers ${PROJECT_BINARY_DIR}/config.h)
# Generate a configuration file
include (GNUInstallDirs)
set (plugin_dir ${CMAKE_INSTALL_LIBDIR}/${PROJECT_NAME})
+set (full_plugin_dir ${CMAKE_INSTALL_FULL_LIBDIR}/${PROJECT_NAME})
configure_file (${PROJECT_SOURCE_DIR}/config.h.in ${PROJECT_BINARY_DIR}/config.h)
include_directories (${PROJECT_SOURCE_DIR} ${PROJECT_BINARY_DIR})