aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 8 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 0446cc3..6544cdb 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,12 @@
project('pdf-simple-sign', 'cpp', default_options : ['cpp_std=c++11'])
cryptodep = dependency('libcrypto')
-executable('pdf-simple-sign', 'pdf-simple-sign.cpp',
+
+executable('pdf-simple-sign', 'pdf-simple-sign.cpp', 'pdf.cpp',
+ install : true,
+ dependencies : cryptodep)
+
+install_headers('pdf-simple-sign.h')
+library('pdf-simple-sign', 'pdf.cpp',
+ soversion : 0,
install : true,
dependencies : cryptodep)