aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2025-01-08 10:54:40 +0100
committerPřemysl Eric Janouch <p@janouch.name>2025-01-11 09:57:59 +0100
commit7aa1e5dd3d80e2664eac7eb0a409829e9785a521 (patch)
treec986a85bce91de498c7470a87da209700dc081ff /meson.build
parent9319d14566e5d1bfec617c479b8543a9ee3ad4ea (diff)
downloadpdf-simple-sign-lpg-libqr.tar.gz
pdf-simple-sign-lpg-libqr.tar.xz
pdf-simple-sign-lpg-libqr.zip
WIP: Add a Lua PDF generatorlpg-libqr
Because Lua compiled for C++ might be hard to find, provide a wrap. Only GitHub releases seem to contain onelua.c, which is a very handy file. WIP: Add documentation, actually get rid of the libqr copy.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 4 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index d68a99d..668b612 100644
--- a/meson.build
+++ b/meson.build
@@ -14,10 +14,10 @@ executable('pdf-simple-sign', 'pdf-simple-sign.cpp',
asciidoctor = find_program('asciidoctor')
foreach page : ['pdf-simple-sign']
custom_target('manpage for ' + page,
- input: page + '.adoc', output: page + '.1',
- command: [asciidoctor, '-b', 'manpage',
+ input : page + '.adoc', output: page + '.1',
+ command : [asciidoctor, '-b', 'manpage',
'-a', 'release-version=' + meson.project_version(),
'@INPUT@', '-o', '@OUTPUT@'],
- install: true,
- install_dir: join_paths(get_option('mandir'), 'man1'))
+ install : true,
+ install_dir : join_paths(get_option('mandir'), 'man1'))
endforeach