aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2024-02-10 05:44:08 +0100
committerPřemysl Eric Janouch <p@janouch.name>2024-02-10 06:04:39 +0100
commit8bcdb0afd5045d30b98798d6a623b7d4f163ef88 (patch)
tree91894de7ae6958ebb68d8e229c885da516341a68 /CMakeLists.txt
parent9dfd89ef06630204109fac52340ae784779952eb (diff)
downloadnncmpp-8bcdb0afd5045d30b98798d6a623b7d4f163ef88.tar.gz
nncmpp-8bcdb0afd5045d30b98798d6a623b7d4f163ef88.tar.xz
nncmpp-8bcdb0afd5045d30b98798d6a623b7d4f163ef88.zip
Bump liberty, install rasterized icons
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cde3640..dd1ee1f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -130,8 +130,22 @@ install (FILES LICENSE DESTINATION ${CMAKE_INSTALL_DOCDIR})
install (DIRECTORY contrib DESTINATION ${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME})
install (DIRECTORY info DESTINATION ${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME})
if (WITH_X11)
+ include (IconUtils)
+
+ set (icon_base ${PROJECT_BINARY_DIR}/icons)
+ set (icon_png_list)
+ foreach (icon_size 16 32 48)
+ icon_to_png (${PROJECT_NAME} ${PROJECT_SOURCE_DIR}/${PROJECT_NAME}.svg
+ ${icon_size} ${icon_base} icon_png)
+ list (APPEND icon_png_list ${icon_png})
+ endforeach ()
+
+ add_custom_target (icons ALL DEPENDS ${icon_png_list})
+
install (FILES ${PROJECT_NAME}.svg
DESTINATION ${CMAKE_INSTALL_DATADIR}/icons/hicolor/scalable/apps)
+ install (DIRECTORY ${icon_base}
+ DESTINATION ${CMAKE_INSTALL_DATADIR})
install (FILES ${PROJECT_NAME}.desktop
DESTINATION ${CMAKE_INSTALL_DATADIR}/applications)
endif ()