aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2022-08-18 01:43:41 +0200
committerPřemysl Eric Janouch <p@janouch.name>2022-08-23 02:50:24 +0200
commit830a744a11a5ebdf57beedfa1bee7fcafb0cc267 (patch)
tree97ab9ac5fc7418077bfd1c31a62ca1a4690c1222 /CMakeLists.txt
parent8260842aef3938b626f34038a80923384366894a (diff)
downloadnncmpp-830a744a11a5ebdf57beedfa1bee7fcafb0cc267.tar.gz
nncmpp-830a744a11a5ebdf57beedfa1bee7fcafb0cc267.tar.xz
nncmpp-830a744a11a5ebdf57beedfa1bee7fcafb0cc267.zip
Add an X11 user interface
This is meant to exactly mimic the terminal UI, just without the restriction to ugly monospace fonts. The Curses implementation has been reworked, and may have become more computationally expensive. In general, though, the codebase has been significantly cleaned up.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 12 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1da79d6..2bb37ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,11 +58,20 @@ if (WITH_PULSE)
list (APPEND extra_libraries ${libpulse_LIBRARIES})
endif ()
+pkg_check_modules (x11 x11 xkbcommon xrender xft fontconfig)
+option (WITH_X11 "Use FFTW to enable spectrum visualisation" ${x11_FOUND})
+if (WITH_X11)
+ if (NOT x11_FOUND)
+ message (FATAL_ERROR "Some X11 libraries were not found")
+ endif ()
+ list (APPEND extra_libraries ${x11_LIBRARIES})
+endif ()
+
include_directories (${Unistring_INCLUDE_DIRS}
${Ncursesw_INCLUDE_DIRS} ${Termo_INCLUDE_DIRS} ${curl_INCLUDE_DIRS}
- ${fftw_INCLUDE_DIRS} ${libpulse_INCLUDE_DIRS})
+ ${fftw_INCLUDE_DIRS} ${libpulse_INCLUDE_DIRS} ${x11_INCLUDE_DIRS})
link_directories (${curl_LIBRARY_DIRS}
- ${fftw_LIBRARY_DIRS} ${libpulse_LIBRARY_DIRS})
+ ${fftw_LIBRARY_DIRS} ${libpulse_LIBRARY_DIRS} ${x11_LIBRARY_DIRS})
# Configuration
if ("${CMAKE_SYSTEM_NAME}" MATCHES "BSD")
@@ -144,7 +153,7 @@ foreach (page ${project_MAN_PAGES})
endforeach ()
# CPack
-set (CPACK_PACKAGE_DESCRIPTION_SUMMARY "MPD client")
+set (CPACK_PACKAGE_DESCRIPTION_SUMMARY "Terminal/X11 MPD client")
set (CPACK_PACKAGE_VENDOR "Premysl Eric Janouch")
set (CPACK_PACKAGE_CONTACT "Přemysl Eric Janouch <p@janouch.name>")
set (CPACK_RESOURCE_FILE_LICENSE "${PROJECT_SOURCE_DIR}/LICENSE")