aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2020-10-10 21:31:31 +0200
committerPřemysl Eric Janouch <p@janouch.name>2020-10-10 21:31:31 +0200
commit525e952753cc218a2be15438689d8ed2f5d97b50 (patch)
treec2dfd8a9ae76e2ea198bcb83e9eeeacd07f9b569 /CMakeLists.txt
parent8707b38c4863f1e8765116064071ee6774e541b3 (diff)
downloadnncmpp-525e952753cc218a2be15438689d8ed2f5d97b50.tar.gz
nncmpp-525e952753cc218a2be15438689d8ed2f5d97b50.tar.xz
nncmpp-525e952753cc218a2be15438689d8ed2f5d97b50.zip
Bump liberty and termo
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 76ca00d..b6cd6d9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,13 +47,13 @@ else (USE_SYSTEM_TERMO)
set (Termo_LIBRARIES termo-static)
endif (USE_SYSTEM_TERMO)
-include_directories (${UNISTRING_INCLUDE_DIRS}
- ${NCURSESW_INCLUDE_DIRS} ${Termo_INCLUDE_DIRS} ${curl_INCLUDE_DIRS})
+include_directories (${Unistring_INCLUDE_DIRS}
+ ${Ncursesw_INCLUDE_DIRS} ${Termo_INCLUDE_DIRS} ${curl_INCLUDE_DIRS})
link_directories (${curl_LIBRARY_DIRS})
# Configuration
include (CheckFunctionExists)
-set (CMAKE_REQUIRED_LIBRARIES ${NCURSESW_LIBRARIES})
+set (CMAKE_REQUIRED_LIBRARIES ${Ncursesw_LIBRARIES})
CHECK_FUNCTION_EXISTS ("resizeterm" HAVE_RESIZETERM)
# Generate a configuration file
@@ -63,8 +63,8 @@ include_directories (${PROJECT_SOURCE_DIR} ${PROJECT_BINARY_DIR})
# Build the main executable and link it
add_executable (${PROJECT_NAME} ${PROJECT_NAME}.c)
-target_link_libraries (${PROJECT_NAME} ${UNISTRING_LIBRARIES}
- ${NCURSESW_LIBRARIES} termo-static ${curl_LIBRARIES})
+target_link_libraries (${PROJECT_NAME} ${Unistring_LIBRARIES}
+ ${Ncursesw_LIBRARIES} termo-static ${curl_LIBRARIES})
add_threads (${PROJECT_NAME})
# Installation