aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-06-22 23:17:25 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-06-23 00:20:08 +0200
commit3ff7867e309e7b4b7435f1ca2b9f73ec7cbd2cfc (patch)
treef4520cd3fa3f7feee782e06238cb0ab5e41780fe /CMakeLists.txt
parent99f35a509c7c8a96078fc03e7646a1c4a5b72e68 (diff)
downloadnncmpp-3ff7867e309e7b4b7435f1ca2b9f73ec7cbd2cfc.tar.gz
nncmpp-3ff7867e309e7b4b7435f1ca2b9f73ec7cbd2cfc.tar.xz
nncmpp-3ff7867e309e7b4b7435f1ca2b9f73ec7cbd2cfc.zip
Bump liberty
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0747132..8061b16 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,9 +3,8 @@ cmake_minimum_required (VERSION 2.8.5)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99")
- set (CMAKE_C_FLAGS_DEBUG
- "${CMAKE_C_FLAGS_DEBUG} -Wall -Wextra -Wno-unused-function")
+ set (wdisabled "-Wno-unused-function -Wno-implicit-fallthrough")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -Wall -Wextra ${wdisabled}")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# Version