aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2022-09-18 09:15:23 +0200
committerPřemysl Eric Janouch <p@janouch.name>2022-09-20 11:04:39 +0200
commit28ed7a85a8cbf3173f17e8ca9f7c8a7d5a7c98ed (patch)
tree3e6f1af6d9bcf195b9b52c4485741ed2c5eec60c /CMakeLists.txt
parentb6dd94072080d29b356d2c22d9f317deac55331d (diff)
downloadnncmpp-28ed7a85a8cbf3173f17e8ca9f7c8a7d5a7c98ed.tar.gz
nncmpp-28ed7a85a8cbf3173f17e8ca9f7c8a7d5a7c98ed.tar.xz
nncmpp-28ed7a85a8cbf3173f17e8ca9f7c8a7d5a7c98ed.zip
Implement lyrics lookup
There is now a generic mechanism for loading lyrics, or any other arbitrary content related to songs.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 543e0c6..23256da 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -104,6 +104,7 @@ foreach (extra m)
endforeach ()
# Generate a configuration file
+include (GNUInstallDirs)
configure_file (${PROJECT_SOURCE_DIR}/config.h.in
${PROJECT_BINARY_DIR}/config.h)
include_directories (${PROJECT_SOURCE_DIR} ${PROJECT_BINARY_DIR})
@@ -123,10 +124,10 @@ target_link_libraries (${PROJECT_NAME} ${Unistring_LIBRARIES}
add_threads (${PROJECT_NAME})
# Installation
-include (GNUInstallDirs)
install (TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
install (FILES LICENSE DESTINATION ${CMAKE_INSTALL_DOCDIR})
install (DIRECTORY contrib DESTINATION ${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME})
+install (DIRECTORY info DESTINATION ${CMAKE_INSTALL_DATADIR}/${PROJECT_NAME})
# Generate documentation from text markup
find_program (ASCIIDOCTOR_EXECUTABLE asciidoctor)