aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-06-22 23:23:57 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-06-22 23:23:57 +0200
commitd37a38c1004352bb726b0afe03fbabe750eec081 (patch)
treeb2a3b618d6b5117fe1a12983387fbb0f2a23742c /CMakeLists.txt
parent93b305e35b9d45d717d15b0222b98641a56ad944 (diff)
downloadneetdraw-d37a38c1004352bb726b0afe03fbabe750eec081.tar.gz
neetdraw-d37a38c1004352bb726b0afe03fbabe750eec081.tar.xz
neetdraw-d37a38c1004352bb726b0afe03fbabe750eec081.zip
Bump liberty
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c37495b..cbb7583 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,8 +4,8 @@ cmake_minimum_required (VERSION 2.8.5)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# -Wunused-function is pretty annoying here, as everything is static
- set (CMAKE_C_FLAGS
- "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra -Wno-unused-function")
+ set (wdisabled "-Wno-unused-function -Wno-implicit-fallthrough")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra ${wdisabled}")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
if ("${CMAKE_SYSTEM_NAME}" MATCHES "BSD")