aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-01-19 00:02:48 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-01-19 00:02:48 +0100
commitc41f3ae529261f3311d5d62620c82443bba3782d (patch)
treecd2a5b74b885ca26a828ed6ffb763478fc4a8dcc /CMakeLists.txt
parent7617e6a0029148040f51b727c2b8401a9f6322e9 (diff)
downloadlogdiag-c41f3ae529261f3311d5d62620c82443bba3782d.tar.gz
logdiag-c41f3ae529261f3311d5d62620c82443bba3782d.tar.xz
logdiag-c41f3ae529261f3311d5d62620c82443bba3782d.zip
Switch to GTK3 via pkg-config, start the port
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ebdefca..4b01a60 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -97,11 +97,11 @@ if (CONVERT_EXECUTABLE AND NOT WIN32)
endif (CONVERT_EXECUTABLE AND NOT WIN32)
# Dependencies
-find_package (GTK2 2.12 REQUIRED gtk)
find_package (JsonGlib REQUIRED)
find_package (PkgConfig REQUIRED)
pkg_search_module (Lua52 REQUIRED lua5.2 lua-5.2 lua>=5.2)
+pkg_check_modules (GTK3 REQUIRED gtk+-3.0)
# Localization
find_package (Gettext REQUIRED)
@@ -229,9 +229,9 @@ glib_genmarshal (${CMAKE_CURRENT_SOURCE_DIR}/liblogdiag/ld-marshal
ld_marshal)
include_directories (${CMAKE_CURRENT_SOURCE_DIR})
-include_directories (${GTK2_INCLUDE_DIRS}
+include_directories (${GTK3_INCLUDE_DIRS}
${JSON_GLIB_INCLUDE_DIRS} ${Lua52_INCLUDE_DIRS})
-set (logdiag_LIBS ${GTK2_LIBRARIES}
+set (logdiag_LIBS ${GTK3_LIBRARIES}
${JSON_GLIB_LIBRARIES} ${Lua52_LIBRARIES})
if (WIN32)