aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-01-18 22:48:03 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-01-18 23:29:53 +0100
commit6e6cf05093bbb907d788641733424677452fb99c (patch)
tree614cf3be91db8335a18e5ee6ee0a41987ccfa426 /CMakeLists.txt
parent36ffb0f8cf9c1c3b6052aebb96714d4bee2fc55b (diff)
downloadlogdiag-6e6cf05093bbb907d788641733424677452fb99c.tar.gz
logdiag-6e6cf05093bbb907d788641733424677452fb99c.tar.xz
logdiag-6e6cf05093bbb907d788641733424677452fb99c.zip
We Lua 5.2 now
Lua 5.1 seems to have been obsoleted. Luckily this was pretty simple.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d50022f..f09c876 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -98,9 +98,11 @@ endif (CONVERT_EXECUTABLE AND NOT WIN32)
# Dependencies
find_package (GTK2 2.12 REQUIRED gtk)
-find_package (Lua51 REQUIRED)
find_package (JsonGlib REQUIRED)
+find_package (PkgConfig REQUIRED)
+pkg_search_module (Lua52 REQUIRED lua5.2 lua-5.2 lua>=5.2)
+
# Localization
find_package (Gettext REQUIRED)
file (GLOB project_PO_FILES ${CMAKE_CURRENT_SOURCE_DIR}/po/*.po)
@@ -228,9 +230,9 @@ glib_genmarshal (${CMAKE_CURRENT_SOURCE_DIR}/liblogdiag/ld-marshal
include_directories (${CMAKE_CURRENT_SOURCE_DIR})
include_directories (${GTK2_INCLUDE_DIRS}
- ${JSON_GLIB_INCLUDE_DIRS} ${LUA_INCLUDE_DIR})
+ ${JSON_GLIB_INCLUDE_DIRS} ${Lua52_INCLUDE_DIRS})
set (logdiag_LIBS ${GTK2_LIBRARIES}
- ${JSON_GLIB_LIBRARIES} ${LUA_LIBRARIES})
+ ${JSON_GLIB_LIBRARIES} ${Lua52_LIBRARIES})
if (WIN32)
find_package (LibIntl REQUIRED)