aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-10-23 14:09:55 +0200
committerPřemysl Eric Janouch <p@janouch.name>2021-10-23 18:01:30 +0200
commit3a087ad581f2e15451bfc12d8ad520422a92f4a8 (patch)
tree443ed750abaabe7bb2db0b8292313136c930561a /CMakeLists.txt
parent4305c603e900173339f0e801c3ab8a55c7141c85 (diff)
downloadlogdiag-3a087ad581f2e15451bfc12d8ad520422a92f4a8.tar.gz
logdiag-3a087ad581f2e15451bfc12d8ad520422a92f4a8.tar.xz
logdiag-3a087ad581f2e15451bfc12d8ad520422a92f4a8.zip
Remove unnecessary DLLs from Windows builds
This saves 20 MiB and 4 MiB of libraries in MSYS2 and bundle builds respectively, in total, without any adverse effects. The MSYS2 build remains bloated, due to the Adwaita icon theme. Bump minimum CMake version to avoid a bug.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 949b20e..5db2c07 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
# The last version with Windows XP support is 3.13, we want to keep that
-cmake_minimum_required (VERSION 3.9)
+cmake_minimum_required (VERSION 3.10)
project (logdiag VERSION 0.2.1 LANGUAGES C)
# Options
@@ -333,8 +333,7 @@ if (WIN32)
install (DIRECTORY
${WIN32_DEPENDS_PATH}/bin/
DESTINATION .
- FILES_MATCHING PATTERN "*.dll"
- PATTERN "libgettext*" EXCLUDE)
+ FILES_MATCHING PATTERN "*.dll")
install (DIRECTORY
${WIN32_DEPENDS_PATH}/etc/
DESTINATION etc)
@@ -366,6 +365,8 @@ if (WIN32)
DESTINATION share/locale)
endif (translation_found GREATER -1)
endforeach (locale)
+
+ install (SCRIPT Win32Cleanup.cmake)
else (WIN32)
install (TARGETS logdiag DESTINATION bin)
install (FILES share/logdiag.desktop DESTINATION share/applications)