aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-06-22 18:14:49 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-06-22 20:42:44 +0200
commitbf534010cb6163bd6ebdef132ee62cccb2b2c9ba (patch)
treea032c00a96a891cc4fc73c882eb55af8d6c8f046 /CMakeLists.txt
parent7b0d7a19e5764aad6fde659e90b1484bde3a4551 (diff)
downloadliberty-bf534010cb6163bd6ebdef132ee62cccb2b2c9ba.tar.gz
liberty-bf534010cb6163bd6ebdef132ee62cccb2b2c9ba.tar.xz
liberty-bf534010cb6163bd6ebdef132ee62cccb2b2c9ba.zip
_init() -> _make() where possible
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2daf01c..6d999e6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,8 @@ cmake_minimum_required (VERSION 2.8.5)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# -Wunused-function is pretty annoying here, as everything is static
- set (CMAKE_C_FLAGS "-std=c99 -Wall -Wextra -Wno-unused-function")
+ set (wdisabled "-Wno-unused-function -Wno-implicit-fallthrough")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra ${wdisabled}")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# Dependencies