aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-07-24 03:46:06 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-07-24 03:46:06 +0200
commit199c56e1418fad52f110328585b47a6ff2956620 (patch)
tree901e1bd7fd781450f05e4cc97b0354ce9f577d62 /CMakeLists.txt
parent6e9217e5d05d95849fbaa795f92eca4ad86b1507 (diff)
downloadliberty-199c56e1418fad52f110328585b47a6ff2956620.tar.gz
liberty-199c56e1418fad52f110328585b47a6ff2956620.tar.xz
liberty-199c56e1418fad52f110328585b47a6ff2956620.zip
Little improvements
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6d999e6..a71d85a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,11 +2,11 @@ project (liberty C)
cmake_minimum_required (VERSION 2.8.5)
# Moar warnings
-if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
+if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUCC)
# -Wunused-function is pretty annoying here, as everything is static
set (wdisabled "-Wno-unused-function -Wno-implicit-fallthrough")
set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra ${wdisabled}")
-endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
+endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUCC)
# Dependencies
set (CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)