aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-02-28 21:18:02 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-02-28 21:18:54 +0100
commitecad324ef338f4dd101b164ea41bb7db19ee582c (patch)
treea140eb96e885df1d4c4bfb4fd22d326863bc51f9 /CMakeLists.txt
parent49600a082b5f906c95c9fb864e59dc7506691b79 (diff)
downloadjson-rpc-shell-ecad324ef338f4dd101b164ea41bb7db19ee582c.tar.gz
json-rpc-shell-ecad324ef338f4dd101b164ea41bb7db19ee582c.tar.xz
json-rpc-shell-ecad324ef338f4dd101b164ea41bb7db19ee582c.zip
Move to liberty
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index adfb404..76e3de4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,8 +3,8 @@ cmake_minimum_required (VERSION 2.8.5)
# Moar warnings
if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
- set (CMAKE_C_FLAGS "-std=c99")
- set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Wall -Wextra")
+ # -Wunused-function is pretty annoying here, as everything is static
+ set (CMAKE_C_FLAGS "-std=c99 -Wall -Wextra -Wno-unused-function")
endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
# Version
@@ -44,7 +44,7 @@ configure_file (${PROJECT_SOURCE_DIR}/config.h.in ${PROJECT_BINARY_DIR}/config.h
include_directories (${PROJECT_BINARY_DIR})
# Build the main executable and link it
-add_executable (${PROJECT_NAME} ${PROJECT_NAME}.c siphash.c)
+add_executable (${PROJECT_NAME} ${PROJECT_NAME}.c)
target_link_libraries (${PROJECT_NAME} ${project_libraries})
# The files to be installed