aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p@janouch.name>2018-10-18 07:44:09 +0200
committerPřemysl Janouch <p@janouch.name>2018-10-18 07:49:36 +0200
commitdf38bcf7758a3b59a15390cd00a16f8807bc055f (patch)
treec9d9a92cc5102a70febaee4cc52d34956b27f021 /CMakeLists.txt
parent2a071d319bc0f28787316b169ce93343b549685d (diff)
parent1c52f9e37ed07e93c21f84779d209ee196360006 (diff)
downloadjson-rpc-shell-df38bcf7758a3b59a15390cd00a16f8807bc055f.tar.gz
json-rpc-shell-df38bcf7758a3b59a15390cd00a16f8807bc055f.tar.xz
json-rpc-shell-df38bcf7758a3b59a15390cd00a16f8807bc055f.zip
Merge in a JSON-RPC 2.0 test server
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58767c6..5b1bd3d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -70,6 +70,16 @@ include_directories (${PROJECT_BINARY_DIR})
add_executable (${PROJECT_NAME} ${PROJECT_NAME}.c http-parser/http_parser.c)
target_link_libraries (${PROJECT_NAME} ${project_libraries})
+# Development tools
+find_package (LibMagic)
+if (LIBMAGIC_FOUND)
+ include_directories (${LIBMAGIC_INCLUDE_DIRS})
+ add_executable (json-rpc-test-server
+ json-rpc-test-server.c http-parser/http_parser.c)
+ target_link_libraries (json-rpc-test-server
+ ${project_libraries} ${LIBMAGIC_LIBRARIES})
+endif ()
+
# The files to be installed
include (GNUInstallDirs)
install (TARGETS ${PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})