aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2018-04-16 15:53:30 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2018-04-16 16:25:44 +0200
commitd8fcb22daf58a65c1e519d13cff7f372ef0313ed (patch)
tree5b97189e8533103041e14ac78d96f46a3dbe168b /CMakeLists.txt
parent989825f7ebcdbcf66e852d903785f20ab76b90a4 (diff)
downloadjson-rpc-shell-d8fcb22daf58a65c1e519d13cff7f372ef0313ed.tar.gz
json-rpc-shell-d8fcb22daf58a65c1e519d13cff7f372ef0313ed.tar.xz
json-rpc-shell-d8fcb22daf58a65c1e519d13cff7f372ef0313ed.zip
Bump liberty, fix GNUC detection, update README
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 465d8b4..172537d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,11 +6,11 @@ option (WANT_READLINE "Use GNU Readline for the UI (better)" ON)
option (WANT_LIBEDIT "Use BSD libedit for the UI" OFF)
# Moar warnings
-if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
+if ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUCC)
# -Wunused-function is pretty annoying here, as everything is static
set (CMAKE_C_FLAGS
"${CMAKE_C_FLAGS} -std=c99 -Wall -Wextra -Wno-unused-function")
-endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUC)
+endif ("${CMAKE_C_COMPILER_ID}" MATCHES "GNU" OR CMAKE_COMPILER_IS_GNUCC)
# Version
set (project_VERSION_MAJOR "0")