aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-02-22 10:54:49 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-02-22 20:06:10 +0100
commit66cf41f89ff8e33413b63a351c05e65b98284b7a (patch)
tree15f344eaee3d693aa519b863fe44fd642820495d /CMakeLists.txt
parent0f2a66e7b0a00af827c26db0a063c01bec65d0a6 (diff)
downloadjson-rpc-shell-66cf41f89ff8e33413b63a351c05e65b98284b7a.tar.gz
json-rpc-shell-66cf41f89ff8e33413b63a351c05e65b98284b7a.tar.xz
json-rpc-shell-66cf41f89ff8e33413b63a351c05e65b98284b7a.zip
Rewrite to use utils.c from ponymap
I'm starting to get tired of repeatingly doing this.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d63f3ce..3dbef75 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,8 +26,12 @@ find_package (LibEV REQUIRED)
include_directories (${dependencies_INCLUDE_DIRS} ${LIBEV_INCLUDE_DIRS})
+# Generate a configuration file
+configure_file (${PROJECT_SOURCE_DIR}/config.h.in ${PROJECT_BINARY_DIR}/config.h)
+include_directories (${PROJECT_BINARY_DIR})
+
# Build the main executable and link it
-add_executable (${PROJECT_NAME} ${PROJECT_NAME}.c)
+add_executable (${PROJECT_NAME} ${PROJECT_NAME}.c siphash.c)
target_link_libraries (${PROJECT_NAME}
${dependencies_LIBRARIES} ${LIBEV_LIBRARIES} readline)