aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2015-03-09 23:32:01 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2015-03-09 23:32:01 +0100
commit5885d1aa69ea10af445713edba0b632a7892f317 (patch)
treeb39e417fd6b5a309d9318c0b8035bc9d97e9cb8b /CMakeLists.txt
parent931fc441f6b89e8fed9c912ddb99d193f99f8b56 (diff)
downloadjson-rpc-shell-5885d1aa69ea10af445713edba0b632a7892f317.tar.gz
json-rpc-shell-5885d1aa69ea10af445713edba0b632a7892f317.tar.xz
json-rpc-shell-5885d1aa69ea10af445713edba0b632a7892f317.zip
Some intial WebSockets code
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6540894..c9c5762 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,12 +22,13 @@ set (CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake)
# Dependencies
find_package (PkgConfig REQUIRED)
pkg_check_modules (dependencies REQUIRED jansson)
+pkg_check_modules (libssl REQUIRED libssl libcrypto)
find_package (LibEV REQUIRED)
find_package (LibMagic REQUIRED)
-set (project_libraries ${dependencies_LIBRARIES}
+set (project_libraries ${dependencies_LIBRARIES} ${libssl_LIBRARIES}
${LIBEV_LIBRARIES} ${LIBMAGIC_LIBRARIES})
-include_directories (${dependencies_INCLUDE_DIRS}
+include_directories (${dependencies_INCLUDE_DIRS} ${libssl_INCLUDE_DIRS}
${LIBEV_INCLUDE_DIRS} ${LIBMAGIC_INCLUDE_DIRS})
# Generate a configuration file