aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2024-04-09 20:47:01 +0200
committerPřemysl Eric Janouch <p@janouch.name>2024-04-09 20:47:01 +0200
commit0bbcbb72070d7f61b5d6e70093e3ccfdc7d091fa (patch)
tree38635275c22107295b8d982379b52d46598a9499 /CMakeLists.txt
parentd57db951aa8b67e413cdd4a59d7d3c6fc06eafd7 (diff)
downloadhex-0bbcbb72070d7f61b5d6e70093e3ccfdc7d091fa.tar.gz
hex-0bbcbb72070d7f61b5d6e70093e3ccfdc7d091fa.tar.xz
hex-0bbcbb72070d7f61b5d6e70093e3ccfdc7d091fa.zip
Fix build on Alpine
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 26ea1a7..3c10b34 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,15 +52,6 @@ if (WITH_LUA)
list (APPEND project_libraries ${lua_LIBRARIES})
include_directories (${lua_INCLUDE_DIRS})
link_directories (${lua_LIBRARY_DIRS})
-
- include (CheckTypeSize)
- set (CMAKE_REQUIRED_LIBRARIES ${lua_LIBRARIES})
- set (CMAKE_REQUIRED_INCLUDES ${lua_INCLUDE_DIRS})
- set (CMAKE_EXTRA_INCLUDE_FILES "lua.h")
- CHECK_TYPE_SIZE (lua_Integer LUA_INTEGER)
- if (NOT HAVE_LUA_INTEGER OR LUA_INTEGER LESS 8)
- message (FATAL_ERROR "Lua must have at least 64-bit integers")
- endif ()
endif ()
pkg_check_modules (x11 x11 xrender xft fontconfig libpng)