aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-02-09 20:12:09 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2017-02-09 20:12:09 +0100
commitfee703567f1b5fce7d7ff2118024b39577bf8711 (patch)
tree443bce295594eb8bea2dac52380c1b2188b1727c /CMakeLists.txt
parentdba39bb612ec7b61d0a440dfe0c3d048b5ecd2ba (diff)
downloaddesktop-tools-fee703567f1b5fce7d7ff2118024b39577bf8711.tar.gz
desktop-tools-fee703567f1b5fce7d7ff2118024b39577bf8711.tar.xz
desktop-tools-fee703567f1b5fce7d7ff2118024b39577bf8711.zip
Add input-switch
Moving common stuff for DDC/CI communicating programs to ddc-ci.c.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 31cbfa1..15e117e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,6 +42,9 @@ add_threads (wmstatus)
add_executable (brightness brightness.c)
target_link_libraries (brightness ${project_libraries})
+add_executable (input-switch input-switch.c)
+target_link_libraries (input-switch ${project_libraries})
+
add_executable (fancontrol-ng fancontrol-ng.c)
target_link_libraries (fancontrol-ng ${project_libraries})
@@ -76,7 +79,7 @@ if (WITH_GDM)
install (TARGETS gdm-switch-user DESTINATION ${CMAKE_INSTALL_BINDIR})
endif (WITH_GDM)
-install (TARGETS wmstatus brightness fancontrol-ng siprandom
+install (TARGETS wmstatus brightness input-switch fancontrol-ng siprandom
DESTINATION ${CMAKE_INSTALL_BINDIR})
install (PROGRAMS shellify DESTINATION ${CMAKE_INSTALL_BINDIR})
install (FILES LICENSE DESTINATION ${CMAKE_INSTALL_DOCDIR})