aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2016-10-12 18:21:36 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2016-10-15 16:05:59 +0200
commit7a32fb8e55d28bd43b546f64a1c20b9246d85e67 (patch)
tree26b8460a1248b87e06ac579429a9c2bfaecc0e7a /CMakeLists.txt
parentb96590664ae645efb740a9ad1b3c08385ade102a (diff)
downloaddesktop-tools-7a32fb8e55d28bd43b546f64a1c20b9246d85e67.tar.gz
desktop-tools-7a32fb8e55d28bd43b546f64a1c20b9246d85e67.tar.xz
desktop-tools-7a32fb8e55d28bd43b546f64a1c20b9246d85e67.zip
Add big-brother
So far this is only rather a prototype.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dba7c34..1d8b307 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,7 +22,7 @@ set (CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/liberty/cmake)
include (AddThreads)
find_package (PkgConfig REQUIRED)
-pkg_check_modules (dependencies REQUIRED libpulse x11)
+pkg_check_modules (dependencies REQUIRED libpulse x11 xext xextproto)
pkg_check_modules (gdm gdm glib-2.0 gio-2.0)
option (WITH_GDM "Compile with GDM support" ${gdm_FOUND})
@@ -54,6 +54,9 @@ endif (WITH_GDM)
add_executable (siprandom siprandom.c)
target_link_libraries (siprandom ${project_libraries})
+add_executable (big-brother big-brother.c)
+target_link_libraries (big-brother ${project_libraries})
+
# The files to be installed
include (GNUInstallDirs)