aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2016-02-14 19:28:22 +0100
committerPřemysl Janouch <p.janouch@gmail.com>2016-02-14 19:28:22 +0100
commit74d634e562323265e8d207200395c2c91cc19299 (patch)
treefbe06b2ebf4b44309c7a30ae224228768bae58f9 /CMakeLists.txt
parent949738401a8c2d02e25af54b078faecdc807a933 (diff)
downloaddesktop-tools-74d634e562323265e8d207200395c2c91cc19299.tar.gz
desktop-tools-74d634e562323265e8d207200395c2c91cc19299.tar.xz
desktop-tools-74d634e562323265e8d207200395c2c91cc19299.zip
Add siprandom
Based on an idea I got from a talk.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5e03bc..14a08a0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,9 @@ if (WITH_GDM)
target_link_libraries (gdm-switch-user ${gdm_LIBRARIES})
endif (WITH_GDM)
+add_executable (siprandom siprandom.c)
+target_link_libraries (siprandom ${project_libraries})
+
# The files to be installed
include (GNUInstallDirs)
@@ -67,7 +70,7 @@ if (WITH_GDM)
install (TARGETS gdm-switch-user DESTINATION ${CMAKE_INSTALL_BINDIR})
endif (WITH_GDM)
-install (TARGETS dwmstatus brightness fancontrol-ng
+install (TARGETS dwmstatus brightness fancontrol-ng siprandom
DESTINATION ${CMAKE_INSTALL_BINDIR})
install (PROGRAMS shellify DESTINATION ${CMAKE_INSTALL_BINDIR})
install (FILES LICENSE DESTINATION ${CMAKE_INSTALL_DOCDIR})