aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Janouch <p.janouch@gmail.com>2017-07-05 20:57:56 +0200
committerPřemysl Janouch <p.janouch@gmail.com>2017-07-05 22:05:07 +0200
commit1fa6f95135cfec036d7f3104816ff2c00208f54c (patch)
treeecfad4defe4328afc405e8f7e64f1f6a10074d63 /CMakeLists.txt
parent456c362811ce8a1eb06f154d70cb2dbb0266d3c4 (diff)
downloaddesktop-tools-1fa6f95135cfec036d7f3104816ff2c00208f54c.tar.gz
desktop-tools-1fa6f95135cfec036d7f3104816ff2c00208f54c.tar.xz
desktop-tools-1fa6f95135cfec036d7f3104816ff2c00208f54c.zip
priod: systemd unit, configuration
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07b0f51..0d53c25 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,13 +72,19 @@ set (SYSTEMD_UNITDIR /lib/systemd/system
configure_file (${PROJECT_SOURCE_DIR}/fancontrol-ng.service.in
${PROJECT_BINARY_DIR}/fancontrol-ng.service @ONLY)
-# System-wide unit files should be installed under /lib and not /usr/lib
-install (FILES ${PROJECT_BINARY_DIR}/fancontrol-ng.service
- DESTINATION "${SYSTEMD_UNITDIR}")
install (FILES fancontrol-ng.conf.example
DESTINATION ${CMAKE_INSTALL_DATADIR}/fancontrol-ng)
-# TODO: priod is also going to need a systemd unit file
+configure_file (${PROJECT_SOURCE_DIR}/priod.service.in
+ ${PROJECT_BINARY_DIR}/priod.service @ONLY)
+install (FILES priod.conf.example
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/priod)
+
+# System-wide unit files should be installed under /lib and not /usr/lib
+install (FILES
+ ${PROJECT_BINARY_DIR}/fancontrol-ng.service
+ ${PROJECT_BINARY_DIR}/priod.service
+ DESTINATION "${SYSTEMD_UNITDIR}")
if (WITH_GDM)
install (TARGETS gdm-switch-user DESTINATION ${CMAKE_INSTALL_BINDIR})