aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 11e615f..ecbabb2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
project (uirc3 C)
-cmake_minimum_required (VERSION 2.8.5)
+cmake_minimum_required (VERSION 2.8.11)
# Options
option (WANT_READLINE "Use GNU Readline for the UI (better)" ON)
@@ -127,12 +127,6 @@ function (make_tests_for target_name)
get_target_property (sources ${target_name} SOURCES)
get_target_property (libraries ${target_name} LINK_LIBRARIES)
- # Unfortunately the property is a 2.8.11 feature however we need to
- # support at least 2.8.7 for now because of Travis CI
- if (NOT libraries)
- set (libraries ${project_libraries})
- endif (NOT libraries)
-
set (test test-${target_name})
add_executable (${test} ${sources})
target_link_libraries (${test} ${libraries})