aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2021-06-15 04:35:41 +0200
committerPřemysl Eric Janouch <p@janouch.name>2021-06-15 07:09:23 +0200
commitb4dd0052ffc60fbd642729a3e05bcadbd6edd6e1 (patch)
tree68676dbb46fc9d1bb1e214ea9116f6ecaca8754b /CMakeLists.txt
parente3c47c33fa3a1fb9412198413962ac35f4483240 (diff)
downloadxK-b4dd0052ffc60fbd642729a3e05bcadbd6edd6e1.tar.gz
xK-b4dd0052ffc60fbd642729a3e05bcadbd6edd6e1.tar.xz
xK-b4dd0052ffc60fbd642729a3e05bcadbd6edd6e1.zip
degesch: pick colours based on relative luminance
Replaces the inaccurate Rec. 709 luma we used to use before. This is the first feature here that requires libm, which doesn't seem to be a particularly great sacrifice. Moreover, I've rectified that the input isn't linear in sRGB, and then was even normalized wrong for the luma formula.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e3dbb7c..acbfb72 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,7 +61,8 @@ endif ()
# -lrt is only for glibc < 2.17
# -liconv may or may not be a part of libc
-foreach (extra iconv rt)
+# -lm may or may not be a part of libc
+foreach (extra iconv rt m)
find_library (extra_lib_${extra} ${extra})
if (extra_lib_${extra})
list (APPEND project_libraries ${extra_lib_${extra}})