aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPřemysl Eric Janouch <p@janouch.name>2020-10-29 15:27:09 +0100
committerPřemysl Eric Janouch <p@janouch.name>2020-10-29 15:27:09 +0100
commit47a4c8beca44d5c07516418c348d77aba5b554fc (patch)
tree753b0c62cc6b653a39b68a6395f86a6bce6751d2 /CMakeLists.txt
parent1de4a2ae3476336535b0602816311776fcd3b586 (diff)
downloadxK-47a4c8beca44d5c07516418c348d77aba5b554fc.tar.gz
xK-47a4c8beca44d5c07516418c348d77aba5b554fc.tar.xz
xK-47a4c8beca44d5c07516418c348d77aba5b554fc.zip
CMakeLists.txt: clean up OpenBSD support
A few things might have changed.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 895f785..540c3c3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -54,8 +54,6 @@ include_directories (${libssl_INCLUDE_DIRS})
link_directories (${libssl_LIBRARY_DIRS})
if ("${CMAKE_SYSTEM_NAME}" MATCHES "BSD")
- include_directories (/usr/local/include)
- link_directories (/usr/local/lib)
# Need this for SIGWINCH in FreeBSD and OpenBSD respectively;
# our POSIX version macros make it undefined
add_definitions (-D__BSD_VISIBLE=1 -D_BSD_SOURCE=1)
@@ -115,7 +113,7 @@ if ((WANT_READLINE AND WANT_LIBEDIT) OR (NOT WANT_READLINE AND NOT WANT_LIBEDIT)
elseif (WANT_READLINE)
# OpenBSD's default readline is too old
if ("${CMAKE_SYSTEM_NAME}" MATCHES "OpenBSD")
- include_directories (/usr/local/include/ereadline)
+ include_directories (${OPENBSD_LOCALBASE}/include/ereadline)
list (APPEND degesch_libraries ereadline)
else ()
list (APPEND degesch_libraries readline)