From b8dc6bb3cc2554f0fbadf37b0178f22e0766df2d Mon Sep 17 00:00:00 2001
From: Přemysl Janouch
Date: Wed, 15 Oct 2014 00:51:05 +0200
Subject: Avoid flicker while resizing
---
CMakeLists.txt | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)
(limited to 'CMakeLists.txt')
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9612bfe..813d86c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,10 +20,6 @@ set (project_VERSION "${project_VERSION_MAJOR}")
set (project_VERSION "${project_VERSION}.${project_VERSION_MINOR}")
set (project_VERSION "${project_VERSION}.${project_VERSION_PATCH}")
-# Configuration
-include (CheckFunctionExists)
-CHECK_FUNCTION_EXISTS ("wcwidth" HAVE_WCWIDTH)
-
# Dependencies
find_package (ZLIB REQUIRED)
find_package (PkgConfig REQUIRED)
@@ -46,6 +42,13 @@ endif (USE_SYSTEM_TERMO)
include_directories (${ZLIB_INCLUDE_DIRS}
${dependencies_INCLUDE_DIRS} ${Termo_INCLUDE_DIRS})
+# Configuration
+include (CheckFunctionExists)
+CHECK_FUNCTION_EXISTS ("wcwidth" HAVE_WCWIDTH)
+
+set (CMAKE_REQUIRED_LIBRARIES ${dependencies_LIBRARIES})
+CHECK_FUNCTION_EXISTS ("resize_term" HAVE_RESIZE_TERM)
+
# Localization
find_package (Gettext REQUIRED)
file (GLOB project_PO_FILES ${CMAKE_CURRENT_SOURCE_DIR}/po/*.po)
--
cgit v1.2.3-70-g09d2