From adce15243ac55b6a1d8a832f21e4eaf6c9e54cf2 Mon Sep 17 00:00:00 2001
From: Přemysl Janouch
Date: Wed, 2 Oct 2013 02:17:38 +0200
Subject: Add a querying tool for use in e.g. IRC bots
Now the tools don't get built on `make all' but instead have their
own target called `tools'. It might be reasonable to move them into
their own directory sometime, instead of cluttering `src'.
---
CMakeLists.txt | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
(limited to 'CMakeLists.txt')
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e2c1373..b9fed6c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,10 +110,16 @@ add_executable (${CMAKE_PROJECT_NAME}
target_link_libraries (${CMAKE_PROJECT_NAME} ${project_common_libraries})
# Tools
-add_executable (add-pronunciation
+add_executable (query-tool EXCLUDE_FROM_ALL
+ src/query-tool.c ${project_common_sources})
+target_link_libraries (query-tool ${project_common_libraries})
+
+add_executable (add-pronunciation EXCLUDE_FROM_ALL
src/add-pronunciation.c ${project_common_sources})
target_link_libraries (add-pronunciation ${project_common_libraries})
+add_custom_target (tools DEPENDS add-pronunciation query-tool)
+
# The files to be installed
include (GNUInstallDirs)
install (TARGETS ${CMAKE_PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})
--
cgit v1.2.3-70-g09d2