From 77968ea165155e0422e3f7fd878306be1f1be66a Mon Sep 17 00:00:00 2001
From: Přemysl Janouch
Date: Tue, 20 Jun 2017 06:26:10 +0200
Subject: CMakeLists.txt: clarify comments
---
CMakeLists.txt | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)
(limited to 'CMakeLists.txt')
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c09ca7b..df62403 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,12 +62,13 @@ if (USE_SYSTEM_TERMO)
message (FATAL_ERROR "System termo library not found")
endif (NOT Termo_FOUND)
else (USE_SYSTEM_TERMO)
+ # We don't want the library to install, even though EXCLUDE_FROM_ALL
+ # sabotages CTest -- those unbuilt tests need to be excluded in CTest runs
add_subdirectory (termo EXCLUDE_FROM_ALL)
- # We don't have many good choices when we don't want to install it and want
- # to support older versions of CMake; this is a relatively clean approach
- # (other possibilities: setting a variable in the parent scope, using a
- # cache variable, writing a special config file with build paths in it and
- # including it here, or setting a custom property on the targets).
+ # We don't have many good choices; this is a relatively clean approach
+ # (other possibilities: setting a variable in the parent scope, using
+ # a cache variable, writing a special config file with build paths in it
+ # and including it here, or setting a custom property on the targets)
get_directory_property (Termo_INCLUDE_DIRS
DIRECTORY termo INCLUDE_DIRECTORIES)
set (Termo_LIBRARIES termo-static)
--
cgit v1.2.3-70-g09d2