aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e9b75b0..8771632 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -179,6 +179,15 @@ add_executable (${PROJECT_NAME}
${project_sources} ${project_headers} ${project_common_sources})
target_link_libraries (${PROJECT_NAME} ${project_common_libraries})
+# Experimental GTK+ frontend, we link it with ncurses but we don't care
+pkg_check_modules (gtk gtk+-3.0)
+if (gtk_FOUND)
+ add_executable (sdgtk EXCLUDE_FROM_ALL
+ src/sdgtk.c ${project_common_sources})
+ target_include_directories (sdgtk PUBLIC ${gtk_INCLUDE_DIRS})
+ target_link_libraries (sdgtk ${gtk_LIBRARIES} ${project_common_libraries})
+endif (gtk_FOUND)
+
# Tools
set (tools add-pronunciation query-tool transform)
foreach (tool ${tools})