summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e2c1373..b9fed6c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -110,10 +110,16 @@ add_executable (${CMAKE_PROJECT_NAME}
target_link_libraries (${CMAKE_PROJECT_NAME} ${project_common_libraries})
# Tools
-add_executable (add-pronunciation
+add_executable (query-tool EXCLUDE_FROM_ALL
+ src/query-tool.c ${project_common_sources})
+target_link_libraries (query-tool ${project_common_libraries})
+
+add_executable (add-pronunciation EXCLUDE_FROM_ALL
src/add-pronunciation.c ${project_common_sources})
target_link_libraries (add-pronunciation ${project_common_libraries})
+add_custom_target (tools DEPENDS add-pronunciation query-tool)
+
# The files to be installed
include (GNUInstallDirs)
install (TARGETS ${CMAKE_PROJECT_NAME} DESTINATION ${CMAKE_INSTALL_BINDIR})